Use tabs to navigate through user menu.

Calling the computer savvy and the mohaa experts
22 posts / 0 new
Last post
Entropy
Entropy's picture
Offline
Last seen: 20 min 27 sec ago
Joined: 05/22/2016 - 23:50
Points: 247

I think its mostly fixed now, i completely removed the sound drivers and got them fresh up... It seems to have worked since i was able to play this afternoon with almost no freezing at all and with a taunt/voice fest going on lol... I also did replace my mohaa with the one you suggested zer! and at start it didn't work but i removed opengl32.dll from the folder and voila, all good Smile

Thank you all for the help, really appreciated as i LuV this game Biggrin see you in the battlefield!

zer!
zer!'s picture
Offline
Last seen: 4 days 3 hours ago
Joined: 08/15/2016 - 19:33
Points: 139

@Entropy, Did you try disabling your sound driver?

Have you tried any other game and observed these freezes?

I hope your MOHAA is clean and not bugged. Just to ensure you can download a clean copy (MOHAAC Approved) from here:

https://mega.nz/#F!OlQy3T5C!1fr-Oqwst3u3tKtyZwnYrw

Jihadi_Paddy
Jihadi_Paddy's picture
Offline
Last seen: 2 weeks 1 day ago
Joined: 07/30/2016 - 16:08
Points: 54

lower all settings to the lowest they can go to. then if you have nvidia, download nvidia gforce experiance and that will automaticly sort out all of your drivers its self.

Slimbips
Slimbips's picture
Offline
Last seen: 1 hour 23 min ago
Joined: 06/25/2015 - 19:46
Points: 4852

time for a new pc

Entropy
Entropy's picture
Offline
Last seen: 20 min 27 sec ago
Joined: 05/22/2016 - 23:50
Points: 247

Well, i've messed a little with my sound drivers, got no improvments there. Checked for virus and malware, run CCleaner and EndItAll, didn't make any noticeable diference too... limited the fps to 60 as it looked the lowest the drop went with slim config and the freezes still happen... I tried running in high priority and no improvments either...

What i mention earlier that appears on the console is:
Error: Playsound needs an alias in ubersound.scr or uberdialog.scr please fix
But this error and something about a tiki pre fetcher(?) are not in sync with the frezzes so not sure if related...

I just left the server as it was very taunt/voice heavy and the game was unbearable to me...

Entropy
Entropy's picture
Offline
Last seen: 20 min 27 sec ago
Joined: 05/22/2016 - 23:50
Points: 247

Does it make much diference? I have been playing for a while with your config, its much much better, i had some lags but might have been connection related... 
Anyway with the config you got me, i have stable 135.6 fps, but when ppl do some taunts they drop like 40, sometime (rarelly) drops to 60 fps... but its way better now, only had a long (1sec) freeze and was with manon voice... I'll try some more things but at least its playble now and i can enjoy the game so thank you very much guys... 

Slimbips
Slimbips's picture
Offline
Last seen: 1 hour 23 min ago
Joined: 06/25/2015 - 19:46
Points: 4852

btw dont do 1366 but do 1360 on the custom resolution

Entropy
Entropy's picture
Offline
Last seen: 20 min 27 sec ago
Joined: 05/22/2016 - 23:50
Points: 247

Hi all and thanks for all the replys

My fps are usually around 99, i guess i have them capped at 100, as they are almost always in th 90s range.

I've recently replaced HD so i have a fresh Win7 install and windows update got all my drivers and says they are up to date. While replacing I have cleaned the laptop inside and aplied new thermal paste to cpu and gpu... I have a dedicated Radeon HD 6670M. I'm running on 1366x768 although i have to type r_mode -1 every time because it somehow doesn't keep that...

I sometime get ERRORs in console saying that someting in "uberdialog" couldn't be found but these errors are not in sync with the freeze and i had them too before the HDD died and this issue wasn't so serious... I hear the taunts so i guess i have the files (for some reason i didnt have them in my previous installation but i've already tried taking out the folder, i stopped hear them but still have freezes)...
I'll try what you guys suggested and give some feedback, i'll start with the unnamedsoldier as i might have messed it up somewhere...

I'll keep you posted and thanks once again...

Entropy

Slimbips
Slimbips's picture
Offline
Last seen: 1 hour 23 min ago
Joined: 06/25/2015 - 19:46
Points: 4852

are u playing on a desktop or laptop?.
drivers installed correctly?.
graphic card dust free?
clean unnamedsoldier with fps cap?.. if not download here mine https://www.dropbox.com/s/uvzolbdlulcg7k5/unnamedsoldier.cfg?dl=0
check the custom resolution on line 60 and 61 and type in your resolution ot play fullscreen.
this is also setup for low pcs, so low graphics etc.
are u sure u dont have have spyware or malware?

download the free PRO edition http://www.superantispyware.com/
https://www.piriform.com/ccleaner
before u start gaming run this program and kill all processes so u have no lag from other programs http://www.docsdownloads.com/enditall-1.htm

before u ask any other questions be sure that u have checked all above.
my experience is that u have to do these things first before u start to think to difficult, if u still have problems u can ask me again.

zer!
zer!'s picture
Offline
Last seen: 4 days 3 hours ago
Joined: 08/15/2016 - 19:33
Points: 139

@Entropy, this is really weird Biggrin

But as Zware suggested, try stabilizing (if not stable) your FPS by using "com_maxfps xxx" command in console. I dont have any dedicated GFX and on Intel HD GFX default is usually 85, which is pretty good. Infact if you have 60 FPS stable you are all set.

However, before doing that, since you mentioned that gamefreezes mostly in taunts / sounds. It could be that certain taunt files are not available in your game folder and while game tries to search that file, it gives a jerk. Though it should not happen, IMO. That being said, sound has the high priortiy while its processes are run by the CPU. There are 2 things that you can try to analyse this further:

1) Disable your sound driver (Control Panel > System Settings > Audio / Sound) and then run MOHAA and see how it goes.

2) I run my MOHAA with high priority. On Windows 7 you can do it once your MOHAA is running, minimize it. Open Task Manager. Find the MOHAA process, right click and change priority to High. CAUTION: DONT CHANGE TO REAL TIME.

If that works then you can make a simple batch file to always run MOHAA with high CPU priortiy as :

____________________________________________________________________________________________________

D:
cd "games\mohaa"
cmd.exe /c "start /high MOHAA.exe"

____________________________________________________________________________________________________

Try these and let us know if that helped.

Cheers.

Pages